Author Topic: Pause not working with scheduler  (Read 2773 times)

Offline trfb516

  • Contributor
  • ***
  • Posts: 16
Pause not working with scheduler
« on: March 26, 2011, 11:16:48 PM »
when scheduler is turned on, selecting a pause (for example - resume in 2 hours) the pause is canceled after a few seconds and dl continue.
if scheduler is off, the pause works fine.

afaik, the scheduler should only control the dl speeds..

abz - 0.37.2 - win7 64 bit
« Last Edit: March 26, 2011, 11:20:04 PM by trfb516 »

Offline Rdl

  • Administrator
  • *****
  • Posts: 3105
Re: Pause not working with scheduler
« Reply #1 on: March 26, 2011, 11:58:19 PM »
Scheduler overrides pause button so it could obey "no downloading" state.

Offline trfb516

  • Contributor
  • ***
  • Posts: 16
Re: Pause not working with scheduler
« Reply #2 on: March 27, 2011, 06:45:15 PM »
it's OK that the scheduler overrides the pause, but y it does it for all the states?
if i define 50% speed for specific hour, that should not interfere with the pause functionality.
if i choose "no download" then the pause should obey this status.

i understand that from the current implementation, one state (no download) dictate the same behavior for all other states...
this is confusing. and i don't think there is any harm changing this behavior.
the scheduler rule is to set speed limits. and the pause to toggle the download on/off
they can co-exists together.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3105
Re: Pause not working with scheduler
« Reply #3 on: March 27, 2011, 07:14:55 PM »
Cause if it didn't, you would have 10%-100% and it would not download cause you have pause on.

However, since it requires few more clicks from user, I could make scheduler not mess with pause button if user have selected pause for xxx minutes feature
« Last Edit: March 27, 2011, 07:19:43 PM by Rdl »

Offline trfb516

  • Contributor
  • ***
  • Posts: 16
Re: Pause not working with scheduler
« Reply #4 on: March 28, 2011, 09:04:39 AM »
i guess i depends how look at this situation, from the pov of the scheduler or the pause.
maybe as you suggested, an option for the user to choose from what behavior to use is the best course of action


10x

Offline elephant66

  • Contributor
  • ***
  • Posts: 55
Re: Pause not working with scheduler
« Reply #5 on: March 29, 2011, 11:54:47 PM »
I set up the scheduler to obey the UK Virgin Media 'fair usage guidelines' otherwise they reduce my speed to 25% or less.

I set the scheduler to not download between 10am to 9pm (each block = do not download)


I run the app at night

but sometime i want to use the Internet
 
before I used to hit pause for 15 to give me 15 minutes (to check something or stream a video)

Then if i 'forget to turn it back on' altbinz unpauses and continues. (rather than me have to remember to restart the app)

With the scheduler this action does not happen :(

I love altbinz because its straight forward.  People are suggesting SABNzb for its compatibility with other apps like Sickbeard etc, but i like altbinz small CPU footprint.

Couldnt pause for 15 minutes turn the scheduler on and off if the scheduler button is running?
Also could the scheduler have an option to remember its on off state on restart?


Cheers



Offline Rdl

  • Administrator
  • *****
  • Posts: 3105
Re: Pause not working with scheduler
« Reply #6 on: March 30, 2011, 12:30:04 PM »
Also could the scheduler have an option to remember its on off state on restart?
This is directly in conflict with 'Autopush scheduler button on startup' function.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3105
Re: Pause not working with scheduler
« Reply #7 on: March 30, 2011, 12:32:29 PM »
I've changed the behaviour so now 'Pause for' function overrides scheduler regarding Pause button. Once Pause for times out, scheduler will unpause.