Author Topic: Massive unresponsiveness and lock ups (0.39.15)  (Read 4608 times)

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Massive unresponsiveness and lock ups (0.39.15)
« on: October 11, 2013, 02:13:29 PM »
This is not related to this version it is something i have seen before, and when it happens i have to cntl+alt+del to kill altbinz.

Try to download something that might have been removed, outside of your retention or has server issues, and alt.binz flashes up unable to connect in the log window and tries to step through the backup servers you have set for each thread/connection.

whilst it is trying to do that, it refuses to respond to any instructions, be it connect, pause, close, stop nothing, have to kill it completely

example in question would be this fileset

http://rapidshare.com/share/30B8D05936F39618AF9A5C2BD5B28822

Offline loginatnine

  • Contributor
  • ***
  • Posts: 6
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #1 on: October 20, 2013, 08:49:42 PM »
+1, got the same thing here

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #2 on: October 21, 2013, 01:20:43 AM »
yeah, it's happening when something doesn't work right, for example right now i am getting can not connect messages 75% of the time on a file set i am trying to download, and because of this Alt Binz is not responding, and is basically locking out control.

It also happens as soon as Alt Binz switches to back up servers, then it is just horrible to use.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #3 on: October 21, 2013, 09:21:07 AM »
SSL?

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #4 on: October 21, 2013, 03:54:48 PM »
backup/secondary servers yes, i do have non ssl primary server though

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #5 on: October 21, 2013, 04:08:01 PM »
Could you try just for test setting backups to regular connection and going again through same problematic nzb?

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #6 on: October 21, 2013, 08:44:56 PM »
ok, i have another problematic one in there at the moment, so i will have a look tonight to construct a new server chain with the non-ssl astraweb servers as the backups, because i know the file retention is outside of the VM servers so it'll be a good test - will post back later


Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #7 on: October 22, 2013, 12:34:45 AM »
ok, same primary, but setup 2 abckups different ports and locations (eu and us)

the file set continued to behave as it did, struggling to connect, the files when downloaded are a train wreck and not repairable, HOWEVER - and this is where it diffeers, the connect and pause buttons now respond as you would expect them to, whereas with my normal setup it's like beating crap out of the delete key at post to get your machine into bios !! and even then it lags more than a drunk after a weekend binge

i'm going to go and setup 2 more backup servers because that would then be an exact replica of my normal config

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #8 on: October 22, 2013, 12:39:59 AM »
yeah, that seems to have fixed it - and oddly enough the files dont seem quite as bad, less can't connect issues.

so it's an SSL issue ? because i'd much rather use the ssl connection, not least because without it the connection is transparent to my ISP and they cripple/throttle by traffic type :(


EDIT: i take that back about the files, biggest train wreck of knackered crap i've downloaded in a long time :lol:
« Last Edit: October 22, 2013, 12:42:00 AM by Slinky »

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #9 on: October 22, 2013, 12:42:09 AM »
"just for test" :)
I'm on it, don't know when it will be finished.

Offline Slinky

  • Contributor
  • ***
  • Posts: 122
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #10 on: October 22, 2013, 08:27:51 PM »
no probs, hope the feedback was helpful in assisting you finding the issue :)

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #11 on: October 27, 2013, 04:46:32 AM »
As I've just posted in the release thread, mine locks up on startup (trying to connect). Just upgraded from .12 to .15.  I have both eu and us servers, both on SSL.

Is it confirmed that this is the cause and is currently broken?

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #12 on: October 27, 2013, 08:20:41 AM »
Nothing is different between .12 and .15 regarding that. Howerever it is known that in certain cases ssl connection can lead to temporary gui lockup.
Your case looks more like something is preventing altbinz from connecting.

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #13 on: October 27, 2013, 10:28:54 AM »
Okay but it actually locks. I can only get out by killing the app.

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #14 on: October 29, 2013, 06:58:06 AM »
right it does eventually come back.

This is 100% repeatable for me. Ver 15 locks on startup for around 60 seconds. Ver 12 with same config etc runs fine and connects immediately. There is therefore obviously something different in the application.

Any ideas how to fix it?