Author Topic: Massive unresponsiveness and lock ups (0.39.15)  (Read 5399 times)

Offline Rdl

  • Administrator
  • *****
  • Posts: 3674
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #15 on: October 29, 2013, 10:03:28 am »
Nothing is different between .12 and .15 regarding that. Howerever it is known that in certain cases ssl connection can lead to temporary gui lockup.
Your case looks more like something is preventing altbinz from connecting.
Teamviewer?

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #16 on: October 29, 2013, 11:50:27 am »
1. Make sure a topic about that does not already exist. You can post in that topic.

I am posting in the existing topic.

2. Please describe the bug as detailed as possible.

Think I've covered it. With version 0.39.12 I have no issues, with version 0.39.15 any "connect" action locks up the application for around 60 seconds.


3. Tell us what your log says, but only copy relevant lines! you can blur out filenames of course.

Code: [Select]
[29/10/2013 9:40:52 PM] [Main] Alt.Binz 0.39.15 [2013-10-02] started.
[29/10/2013 9:40:52 PM] [Main] Windows 7 or Windows Server 2008 R2
[29/10/2013 9:40:53 PM] [Main] 0 items loaded into download history list in 0ms.
[29/10/2013 9:40:53 PM] [Main] 0 outdated items removed from download history list in 0ms.
[29/10/2013 9:40:54 PM] [T1] Hello
[29/10/2013 9:40:54 PM] [T2] Hello
[29/10/2013 9:40:54 PM] [T3] Hello

that last line repeats for each attempted connection up to 60.

Then:

Code: [Select]
29/10/2013 9:40:55 PM] [T2] Connecting (Easynews EU)
[29/10/2013 9:40:55 PM] [T1] Connecting (Easynews EU)
[29/10/2013 9:40:55 PM] [T4] Connecting (Easynews EU)
[29/10/2013 9:40:55 PM] [T6] Connecting (Easynews EU)
[29/10/2013 9:40:55 PM] [T10] Connecting (Easynews EU)
[29/10/2013 9:40:55 PM] [T14] Connecting (Easynews EU)
.
.
<repeats>
.
.
[29/10/2013 9:43:34 PM] [T34] Could not connect (Easynews US) 
[29/10/2013 9:43:34 PM] [T18] Could not connect (Easynews EU) 
[29/10/2013 9:43:34 PM] [T38] Could not connect (Easynews US)
.
etc
.

4. If you can reproduce it, tell us the steps necessary for it to be reproduced.

As above. If already connected then simply press the "connect" button to disconnect and then again. Or start the application.


5. Tell us your OS, firewall and Alt.Binz version (you can find that by clicking on the about button).

alt.binz versions as above. Windows 7 Ultimate x64, using Microsoft Security Essentials.

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #17 on: October 29, 2013, 11:52:09 am »
Nothing is different between .12 and .15 regarding that. Howerever it is known that in certain cases ssl connection can lead to temporary gui lockup.
Your case looks more like something is preventing altbinz from connecting.
Teamviewer?

I do have Teamviewer loaded but quitting it makes no difference.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3674
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #18 on: October 29, 2013, 11:55:10 am »
Err, I was thinking can I verify things via Teamviewer...

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #19 on: October 29, 2013, 12:02:20 pm »
Sorry, misunderstood.

Can we try it tomorrow? It's a little late here now.

Offline zer0gig

  • Contributor
  • ***
  • Posts: 9
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #20 on: October 30, 2013, 12:33:59 am »
I'm also having lock ups with 0.39.15. When I search binsearch, it freezes for about 15 seconds and then unfreezes with the results. Also when it connects to my news server (yup it's SSL) it freezes for about 5 seconds. This didn't happen a few versions back, 0.39.12 maybe, I can't remember how far back.

Edit:

Ok so the binsearch freeze only happens when the SSL box is enabled for searching. Binsearch is currently under maintenence and isn't delivering any results so I guess Alt.binz is waiting for a timeout but it's freezing while doing that. When SSL isn't enabled it just says no results instantly.
« Last Edit: October 30, 2013, 12:37:43 am by zer0gig »

Offline DipDancer

  • Contributor
  • ***
  • Posts: 16
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #21 on: November 08, 2013, 04:03:35 pm »
also have this problem for the first time now. the gui just behaves very laggy. this also affects scrolling and staccato download status bars.

never had this problem before.

edit: disappeared after restating altbinz though.
« Last Edit: November 08, 2013, 04:05:22 pm by DipDancer »

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #22 on: November 09, 2013, 12:09:16 am »
I've gone back to .12 and no issues with ssl. Will try again whenever the next version comes out.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3674
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #23 on: November 09, 2013, 01:17:05 pm »
Possible solution for ssl hangups while connecting. Redownload 0.39.15

It is not a fix for gui unresponsiveness while downloading at high speed!

Offline gadgetguy

  • Contributor
  • ***
  • Posts: 20
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #24 on: November 09, 2013, 02:53:58 pm »
Seems to have worked for me. Thanks.

Offline auriga1000

  • Contributor
  • ***
  • Posts: 13
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #25 on: November 10, 2013, 05:48:50 pm »
for me as well. thanks

Offline Slinky

  • Contributor
  • ***
  • Posts: 149
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #26 on: November 12, 2013, 07:31:04 pm »
Possible solution for ssl hangups while connecting. Redownload 0.39.15

It is not a fix for gui unresponsiveness while downloading at high speed!

grabbing it now, will let you know how i get on over hte next few days or so

thx

Offline useless

  • Contributor
  • ***
  • Posts: 39
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #27 on: November 20, 2013, 12:59:14 pm »
hmmm downloaded it again and it cleared the problem up. cheers rdl

Offline Slinky

  • Contributor
  • ***
  • Posts: 149
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #28 on: November 23, 2013, 06:47:45 pm »
ok, I've had some time with this fresh build, since my last post and I can confirm the GUI lockups seem to have gone, I still get a small pause as it switches from my primary server to secondary using SSL is there, and the drop in speed is quite noticeable (as it always is) when you get the cant connect or file not available and it switches, but, other than that the unresponsiveness seems to have been cured :)

thanks

obviously I'll still be keen to see future plans / developments for those like me that like to run one free isp server switching into a pay per download secondary server, being able to switch manually from a button in the top bar would be handy

Offline wtfchuck

  • Contributor
  • ***
  • Posts: 6
Re: Massive unresponsiveness and lock ups (0.39.15)
« Reply #29 on: December 01, 2013, 04:36:48 am »
Whew, much better.