Author Topic: Files downloading normally, but status bar remains 0%, no file appears  (Read 1128 times)

Offline A320

  • Contributor
  • ***
  • Posts: 22
So this just started happening to me today after switching providers and setting up the new servers.  I'm on 0.46 Win10 and now with Newsgroup Ninja.

The intended file will download normally according to the action bars and timers on the bottom but the progress/status bar remains at 0%.  It appears to complete but then the progress/status bar just disappears! 

When starting a subsequent download, suddenly the previous, unfinished one progress bar reappears and quickly goes from 0 to 100% and shows completed and the file magically appears in it's intended download location.

Strangest thing, can anyone help?  I tried searching the forum.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3721
As always all the info is in the detailed log. I think it's full of 430 not found errors.

Offline A320

  • Contributor
  • ***
  • Posts: 22
I'll try and find the log and get right back to you.  thanks.

Offline A320

  • Contributor
  • ***
  • Posts: 22
Files downloading normally, but status bar remains 0%, no file appears
« Reply #3 on: April 23, 2019, 01:42:20 am »
below

Offline A320

  • Contributor
  • ***
  • Posts: 22
As always all the info is in the detailed log. I think it's full of 430 not found errors.

Think I found the log:

For whatever reason it appears that it's the decoding it gets hung up on.  As an example, I started with a clean slate, downloaded a file, progress bar never moves from 0% but the status on the lower half shows active downloading and a timer countdown.  When it all finishes, everything stops and the progress bar simply disappears and nothing else happens.  Then if I restart alb.binz, it the progress bar of the said file reappears and quickly counts up to 100% (as if it was checking the file) and the decoding/unraring begins!  Again this behavior only seems to have started when I changed newsgroup providers as dumb as that sounds.

The log shows this after the restart and didn't see any "errors" anywhere:

[2019-04-22 12:43:43 PM] [T13] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx08.am4)
[2019-04-22 12:43:43 PM] [T5] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx15.am4)
[2019-04-22 12:43:43 PM] [T11] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx12.am4)
[2019-04-22 12:43:43 PM] [T6] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx36.am4)
[2019-04-22 12:43:43 PM] [T27] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx26.fr7)
[2019-04-22 12:43:43 PM] [Dec] Yenc file **changed the name of the file***.part04.rar decoded in 2187ms
[2019-04-22 12:43:44 PM] [T22] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx24.fr7)
[2019-04-22 12:43:44 PM] [T23] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx21.fr7)
[2019-04-22 12:43:44 PM] [T30] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx26.fr7)
[2019-04-22 12:43:44 PM] [T16] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx21.fr7)
[2019-04-22 12:43:44 PM] [T21] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx20.fr7)

[2019-04-22 12:43:44 PM] [T3] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx08.am4)
[2019-04-22 12:43:44 PM] [T1] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx15.am4)
[2019-04-22 12:43:44 PM] [T12] Connected & Authenticated (Newsgroup Ninja) - 200 Welcome (fx08.am4)
[2019-04-22 12:43:45 PM] [Dec] Yenc file **changed the name of the file***.part05.rar decoded in 1531ms
[2019-04-22 12:43:47 PM] [Dec] Yenc file **changed the name of the file***.part06.rar decoded in 1500ms
[2019-04-22 12:43:48 PM] [Dec] Yenc file **changed the name of the file***.part07.rar decoded in 1516ms
[2019-04-22 12:43:50 PM] [Dec] Yenc file **changed the name of the file***.part08.rar decoded in 1500ms
[2019-04-22 12:43:52 PM] [Dec] Yenc file **changed the name of the file***.part09.rar decoded in 1516ms
[2019-04-22 12:43:54 PM] [Dec] Yenc file **changed the name of the file***.part10.rar decoded in 2140ms
[2019-04-22 12:43:56 PM] [Dec] Yenc file **changed the name of the file***.part11.rar decoded in 2000ms
[2019-04-22 12:43:58 PM] [Dec] Yenc file **changed the name of the file***part12.rar decoded in 1500ms
[2019-04-22 12:43:59 PM] [Main] Download queue list ageing done in 0ms
[2019-04-22 12:44:00 PM] [Dec] Yenc file **changed the name of the file*** decoded in 1547ms
[2019-04-22 12:44:01 PM] [Dec] Yenc file **changed the name of the file***.rar decoded in 1547ms
etc
etcetc
[2019-04-22 12:44:16 PM] [PAR2&Unrar] "F:\**changed the name of the file***.part01.rar" unrar started
[2019-04-22 12:44:16 PM] [PAR2&Unrar] Source dir: F:\**changed the name of the file***~\
[2019-04-22 12:44:16 PM] [PAR2&Unrar] Unrar dir: F:\**changed the name of the file***\
[2019-04-22 12:44:57 PM] [PAR2&Unrar] F:\**changed the name of the file*** extracted ok
[2019-04-22 12:44:57 PM] [PAR2&Unrar] F:\**changed the name of the file*** extracted ok
[2019-04-22 12:44:57 PM] [PAR2&Unrar] F:\**changed the name of the file*** extracted ok
[2019-04-22 12:44:57 PM] [PAR2&Unrar] "F:\**changed the name of the file***part01.rar" unrar finished
[2019-04-22 12:46:43 PM] [T36] Disconnected - code 0

Offline A320

  • Contributor
  • ***
  • Posts: 22
more info, if I add subsequent downloads nothing happens, everything just remains hung on that prior download showing 0% even though it is completed.  A restart of the program kicks something into gear as suddenly that intitial download resumes "decoding" then unraring and the others in the queue start downloading again until the next one is done and the problem happens all over again!  Very strange and nothing in the logs that I can see.

Offline A320

  • Contributor
  • ***
  • Posts: 22
It just appears that it's stuck on the "decoding" process if you examine the following 2 screenshots.  They were taken once the downloading was complete and the status bar disappears.  When I expand the NZB subject, you can see it says decoding but nothing is happening.  When I restart the application, it all of a sudden starts decoding:

https://imgur.com/a/1zWAkfZ

Offline Rdl

  • Administrator
  • *****
  • Posts: 3721
When I say detailed log it's full uncut log file with detailed logging on. Upload it somewhere and send a link to me via pm.

Offline A320

  • Contributor
  • ***
  • Posts: 22
When I say detailed log it's full uncut log file with detailed logging on. Upload it somewhere and send a link to me via pm.

sent

Offline Rdl

  • Administrator
  • *****
  • Posts: 3721
Is this behaviour specific for some nzbs or all?
There were some decoding changes in 0.46.0.4 so maybe try lower version.
Log says that at the moment of decoding not a single encoded part of the file couldn't be found. But, after restart they are there. Is something blocking the access to those files?
Quick way to see if that is the case is to enable memory cache option in altbinz that can hold at least one full file. If that works, the problems is AV or something similar.

Offline A320

  • Contributor
  • ***
  • Posts: 22
Re: Files downloading normally, but status bar remains 0%, no file appears
« Reply #10 on: April 24, 2019, 02:48:08 am »
Is this behaviour specific for some nzbs or all?
There were some decoding changes in 0.46.0.4 so maybe try lower version.
Log says that at the moment of decoding not a single encoded part of the file couldn't be found. But, after restart they are there. Is something blocking the access to those files?
Quick way to see if that is the case is to enable memory cache option in altbinz that can hold at least one full file. If that works, the problems is AV or something similar.

Thank you for the reply.

Is this behaviour specific for some nzbs or all?

ALL NZB's

If that works, the problems is AV or something similar.
My AV (ESET) has been the same for years.  No other major changes to my PC, this problem started I believe since the last update.  What is the best/easiest way to roll back?   Will I have to delete all my appdata content and start from scratch?  ***edited to add, I forgot that I troubleshooted this by turning the AV completely OFF, no changes.

Quick way to see if that is the case is to enable memory cache option in altbinz that can hold at least one full file. If that works, the problems is AV or something similar.

I'll try this and report back as well.

Thanks again.
« Last Edit: April 24, 2019, 02:50:39 am by A320 »

Offline A320

  • Contributor
  • ***
  • Posts: 22
Re: Files downloading normally, but status bar remains 0%, no file appears
« Reply #11 on: April 24, 2019, 02:53:48 am »
Quick way to see if that is the case is to enable memory cache option in altbinz that can hold at least one full file. If that works, the problems is AV or something similar.

Tried the max value of 2000mb, no changes after a restart of the program.  Only thing left to try is rolling back, but just want to make sure I do that properly.  Do I need to delete the appdata folder and anything else?


Offline Rdl

  • Administrator
  • *****
  • Posts: 3721
Re: Files downloading normally, but status bar remains 0%, no file appears
« Reply #12 on: April 24, 2019, 07:25:10 am »
To be sure. backup appdata folder and start fresh with that lower version. After try you can restore appdata and latest version.

Offline A320

  • Contributor
  • ***
  • Posts: 22
Re: Files downloading normally, but status bar remains 0%, no file appears
« Reply #13 on: April 24, 2019, 05:05:54 pm »
To be sure. backup appdata folder and start fresh with that lower version. After try you can restore appdata and latest version.

So before I got your reply I tried 0.45.1 with the same appdata and everything was working normally again.  Downloads and decodes automatically.  So definitely a decoding problem for me with 0.46 I guess  :-\

Offline A320

  • Contributor
  • ***
  • Posts: 22
Re: Files downloading normally, but status bar remains 0%, no file appears
« Reply #14 on: April 25, 2019, 12:45:51 am »
This is becoming more strange.....now some NZB's are hanging on decoding while using 0.45.1.  Like before, after restarting alt.binz everything kicks into gear and the decoding begins and completes with unraring.