Author Topic: RSS downloader stopped working  (Read 6879 times)

Offline fiddy

  • Contributor
  • ***
  • Posts: 46
Re: RSS downloader stopped working
« Reply #15 on: September 25, 2010, 03:27:50 PM »
Just started from scratch - got the cookies and added the feed in , tried to add to the queue but this time i got a heap of html in the nzb file - what am i looking for in particular to diagnose ? Or can i just post one here safely - ie will it contain sensitive data.

thx

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS downloader stopped working
« Reply #16 on: September 25, 2010, 07:59:15 PM »
fiddy, you just need to give us the gist of what the error message is, or what site page it's redirecting to.

Offline wvnispen

  • Contributor
  • ***
  • Posts: 17
Re: RSS downloader stopped working
« Reply #17 on: September 26, 2010, 06:52:17 AM »

Quote
Or you could use the far better nzbs.org instead. I really don't understand the appeal of NZBMatrix myself.


I do use nzbs.org for manual downloads.  My buddy advised me to use the RSS feed from NZBMatrix. Will be switching to nzbs.org's now.

Thanks for the help.

Wynand


Offline Ripleyonline

  • Contributor
  • ***
  • Posts: 2
Re: RSS downloader stopped working
« Reply #18 on: September 26, 2010, 02:07:38 PM »
If you have problems with nzbmatrix rss feed they changed the feed a cuple of days ago. They changed i back last night thou because of all the problems so if you generate a new rss feed today it should solve your problem. It sure solved mine....

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS downloader stopped working
« Reply #19 on: September 26, 2010, 02:35:07 PM »
lol @ NZBMatrix

Thanks for reporting. :)

Offline wvnispen

  • Contributor
  • ***
  • Posts: 17
Re: RSS downloader stopped working
« Reply #20 on: September 27, 2010, 06:13:46 AM »
Hi,

I changed to nzbs.org and had the same issue. The feed comes in but  nothing gets downloaded.  If I click on a line and say add to queue nothing still happens.

Now I am puzzled.

Wynand

Offline wvnispen

  • Contributor
  • ***
  • Posts: 17
Re: RSS downloader stopped working
« Reply #21 on: September 27, 2010, 06:17:20 AM »
Hi,

Just changed back to NZBMatrix and all works again...even right click add to queue.

Wynand

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS downloader stopped working
« Reply #22 on: September 27, 2010, 08:47:09 AM »
Alt.Binz works perfectly with nzbs.org.  You need to add &dl=1 to the url as well as your i and h values, as the site specifies here:

http://nzbs.org/index.php?action=rss



Offline wvnispen

  • Contributor
  • ***
  • Posts: 17
Re: RSS downloader stopped working
« Reply #23 on: September 28, 2010, 04:36:05 PM »
Hi Guys,

All is not well in the land of auto downloads. I thought it was and by golly NZBMatrix did it again.  So I moved all back to nzbs.org and added all the stuff as per the post above.  I can see matches happen (pink goes green) but it still doesn't download the file.

I am confused. Where can I look?

Thanks
Wynand
 ???

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS downloader stopped working
« Reply #24 on: September 28, 2010, 10:32:59 PM »
@ wvnispen

I'm not sure what you're doing, but I've just tested again and nzbs.org feeds work no problem with Alt.Binz.  Your url should look something like this:

http://nzbs.org/rss.php?catid=1&i=<your_id>&h=<your_hash>&dl=1

Note the &dl=1 at the end.

Quote
• To change the default link to download (with above): &dl=1
http://nzbs.org/index.php?action=rss



Offline wvnispen

  • Contributor
  • ***
  • Posts: 17
Re: RSS downloader stopped working
« Reply #25 on: September 30, 2010, 05:39:53 AM »
Hi,

Thanks for the reply. I had the link correct. I uninstalled and re-installed alt.binz and redo all the setings and all with nzbs.org is working 100%.  Guess NZBMatrix was a waste.

Wynand

Offline gix

  • Contributor
  • ***
  • Posts: 4
Re: RSS downloader stopped working
« Reply #26 on: October 31, 2010, 02:25:30 PM »
I have a problem with the RSS and Alt.Binz. until the other day everything was going well with the automatic download, but then the download stopt working. It will not even ADD TO QUEUE option.
Can anyone help me with settings for the RSS feed from nzbmatrix site for Alt.Binz ver:0.31.8.
Thanks...

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: RSS downloader stopped working
« Reply #27 on: October 31, 2010, 02:49:56 PM »
Don't bother. The problem is nzb that is served by nzbmatrix. It's obviously out of specification.

Normal NZB:
Code: [Select]
<?xml version="1.0" encoding="ISO-8859-1" ?>
<!DOCTYPE nzb PUBLIC "-//newzBin//DTD NZB 0.9//EN" "http://www.newzbin.com/DTD/nzb/nzb-0.9.dtd">
<nzb xmlns="http://www.newzbin.com/DTD/2003/nzb">

<file subject="something" date="sometime" poster="someone">

NZB served by nzbmatrix rss:
Code: [Select]
<?xml version="1.0" encoding="iso-8859-1" ?><file subject="something" date="sometime" poster="someone">

I'll release today a version that handles those types of nzbs also.

Offline Snorbitz

  • Contributor
  • ***
  • Posts: 1
Re: RSS downloader stopped working
« Reply #28 on: November 04, 2010, 08:14:17 AM »
Still getting the blank NZB's from NZBMatrix....... Any ideas?
 ???

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: RSS downloader stopped working
« Reply #29 on: November 04, 2010, 10:51:43 AM »
Still getting the blank NZB's from NZBMatrix....... Any ideas?
 ???
I've just checked. It works. Post your url with masked username and apikey