Author Topic: Kein automatisches Entpacken  (Read 1561 times)

Offline knightrider

  • Contributor
  • ***
  • Posts: 46
Kein automatisches Entpacken
« on: April 03, 2021, 01:36:52 PM »
Ich nutze die aktuellste Version (0.47.3.4).
AltBinz entpackt die geladenen RARs nicht, obwohl das Passwort in geschweifter Doppelklammer am Ende des nzb-Namens steht.
Ich finde auch keine Option in den Einstellungen. Bisher hat das jedoch immer geklappt.

Hat noch jemand dieses Problem?

Offline abismo

  • Contributor
  • ***
  • Posts: 67
Re: Kein automatisches Entpacken
« Reply #1 on: April 03, 2021, 11:43:13 PM »
Kommt das bei allen nzb's mit Klammer Passwort vor?
Funktioniert das Passwort, aus den Klammern denn, wenn du manuell entpackst?
Prüf mal mit Shift+Strg+P, ob das Passwort überhaupt übernommen worden ist, wenn Du so ne nzb reinlädst!

Offline knightrider

  • Contributor
  • ***
  • Posts: 46
Re: Kein automatisches Entpacken
« Reply #2 on: April 04, 2021, 12:33:35 AM »
Ganz vergessen zu erwähnen.
Wenn ich manuell entpacke, funktioniert das PW problemlos.
Heißt, es wird also beim manuellen Hinzufügen übernommen.
Nur warum funktioniert es nicht (mehr) mit der geschweiften Doppelklammer {{....}}

Offline abismo

  • Contributor
  • ***
  • Posts: 67
Re: Kein automatisches Entpacken
« Reply #3 on: April 04, 2021, 03:07:26 AM »
Also bei mir funktioniert es ganz normal. Wie sieht es mit Passwörtern aus, die als meta-tag integriert sind?
Woher beziehst du denn deine nzb's? Erstellst du sie mit NZBDonkey? Wenn Du Lust hast, dann schick mal so eine nzb rüber als PM!?
Dann teste ich das mal für dich, ob die hier auch Probleme machen.
Meine Neugier ist getriggert  ;D

Offline knightrider

  • Contributor
  • ***
  • Posts: 46
Re: Kein automatisches Entpacken
« Reply #4 on: April 04, 2021, 10:08:04 AM »
Es spielt keine Rolle, ob ich die nzb mit nzbdonkey erstellen lasse oder sie manuell lade.
Entpacken geht nicht, egal welche nzb ich teste.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3853
Re: Kein automatisches Entpacken
« Reply #5 on: April 04, 2021, 10:30:34 PM »
Prüf mal mit Shift+Strg+P, ob das Passwort überhaupt übernommen worden ist, wenn Du so ne nzb reinlädst!
Works as expected here with {{password}}

Offline Sucker76

  • Contributor
  • ***
  • Posts: 229
Re: Kein automatisches Entpacken
« Reply #6 on: April 05, 2021, 08:18:37 AM »
Hoppla, habe ich doch glatt die neue Version verschlafen, hatte bis eben noch die 0.47.3.3 laufen, aber egal.
Auch die neue Version entpackt hier so wie sie es soll.

Also wenn das Passwort richtig in der doppelten geschweiften Klammer steht und nicht etwa eine Klammer fehlt oder eckige oder runde Klammern genommen wurden, dann übernimmt ein korrektes AltBinz das auch korrekt.

Wenn du in der Warteschlange einen Download mit der rechten Maustaste anklickst, kannst du "Passwort setzen" auswählen. Ein bereits übernommenes Passwort wird dir dann auch dort angezeigt.
Das meinte abismo mit STR+SHIFT+P.
Wird dir das Passwort da richtig angezeigt?
Wenn ja ist dein AltBinz vermutlich irgendwo defekt, installiere es neu.

Wenn nein, könnte es sein, dass innerhalb der NZB ein Passwort als Meta-Tag hinterlegt wurde, welches nicht korrekt ist. In dem Falle übernimmt AltBinz das Passwort aus der NZB, egal was in {{}} steht.

Öffne eine der NZBs mit einem Texteditor und suche (mit STRG+F) nach dem Begriff password.
Wenn du so etwas findest, dann ist ein Passwort in die NZB eingebettet und sieht so aus:
Code: [Select]
<meta type="password">sW0rdf1sh</meta>Zwischen den beiden "Meta" Tags <meta type="password"> und </meta> steht das Passwort.
Hier also sW0rdf1sh

Wenn das ein anderes, falsches Passwort ist, kann Altbinz damit nichts anfangen und natürlich auch nicht entpacken. Vielleicht wäre an der Stelle eine Meldung "password incorrect" im Log-Fenster nicht schlecht...

Frohe Ostern

Offline knightrider

  • Contributor
  • ***
  • Posts: 46
Re: Kein automatisches Entpacken
« Reply #7 on: April 05, 2021, 04:04:26 PM »
Nachdem ich mir nun die halbe Nacht um die Ohren gehauen und meinen Rechner, der grafikseitig angefangen hatte rumzuspinnen, komplett neu aufgesetzt habe, funktioniert auch das automatische Entpacken wieder. Ich muss aber hinzufügen, dass ich jetzt avast NICHT mehr nutze. Es kann gut sein, dass dieser AV-Scanner Probleme gemacht hat, sowohl was die Grafik als auch die Funktion von AltBinz betrifft.
Sei´s drum.
Danke an alle, die versucht haben, mein Problem zu lösen.

P.S.
Kann mir jemand verraten, ob es die Funktion "Pausieren wenn kein Passwort hinzugefügt" oder so ähnlich in AltBinz gibt?
Habe zweimal die kompletten Settings durchgeschaut, jedoch nichts gefunden.

Gruß

Offline Sucker76

  • Contributor
  • ***
  • Posts: 229
Re: Kein automatisches Entpacken
« Reply #8 on: April 05, 2021, 07:32:09 PM »
OK, Hauptsache es geht wieder.

Unter Sonstiges #3:
Rar password checker mode
Warn/Pause

Dann gibt es ein PopUp und der Download wird pausiert.

Offline reisender67

  • Contributor
  • ***
  • Posts: 38
Re: Kein automatisches Entpacken
« Reply #9 on: April 11, 2021, 02:24:16 PM »
Hi,

ich habe in letzter Zeit festgestellt, dass es jetzt häufiger doppelt gepackte Dateien gibt.
Alt.Binz entpackt nach dem Download scheinbar nur die erste Ebene (wird auch unter der Registerkarte "PAR2" dann als entpackt angezeigt). Die jetzt nach dem ersten entpackten vorhandenen RAR oder ZIP Dateien müssen dann nochmals manuell entpackt werden.

Beste Grüße
Christian
Es muss immer weiter gehen!

Offline Sucker76

  • Contributor
  • ***
  • Posts: 229
Re: Kein automatisches Entpacken
« Reply #10 on: April 11, 2021, 08:25:43 PM »
Ja, das ist richtig, da verhält sich AltBinz so wie es soll.
Es gibt andere Reader, die entpacken jeweils solange, bis wirklich alles entpackt ist.
Kannst es ja mal als Feature Request anfragen, auch wenn es für meine Bedürfnisse nicht immer die beste Wahl ist. Aber normalerweise bekommen wir für so etwas ja einen Schalter wo man es an und ausknipsen kann.