Author Topic: Speed throttling not working correctly in v42.0  (Read 982 times)

Offline therealjoeblow

  • Contributor
  • ***
  • Posts: 63
Speed throttling not working correctly in v42.0
« on: April 21, 2016, 02:39:15 AM »
In v39.15 when I set my max speed to 3200kb/s, and then the speed throttle at the lower right (or in my scheduler) to 50%, it showed 1600kb/s, and actually throttled the speed correctly to almost exactly that rate.

Now with v42, it still "shows" 1600, but it throttles the speed to between 650-680 kb/s, not 1600 as expected. 

The throttling rates are proportional to what I reported above if you set to other %'ages, or set the max speed to something else, it doesn't throttle the speed to the expected rate anymore like it did in v39.15.

Is there some other hidden setting I need to adjust with the new server setup?  Or is this a bug?

Thanks
TRJB

Offline gigurtsis

  • Contributor
  • ***
  • Posts: 10
Re: Speed throttling not working correctly in v42.0
« Reply #1 on: April 30, 2016, 11:10:14 AM »
I get the same problem with v42. Have tried recreating my alt.binz profile, which didn't help.

My max download speed is 1250 KBps, and setting the limit at 50% shows 625 KBps at the speed limit, but alt.binz actually downloads at about 250 Kbps.

I found setting my max download speed to 2.5x the actual value makes the speed limit download at the right rate. At 50%, with a max download speed of 3125 KBps, alt.binz downloads around 630 KBps.

Thanks

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Speed throttling not working correctly in v42.0
« Reply #2 on: April 30, 2016, 11:20:46 AM »
For sure bug. Didn't take a look yet, but I guess backup servers are counted and speed is divided between all levels.

Offline gigurtsis

  • Contributor
  • ***
  • Posts: 10
Re: Speed throttling not working correctly in v42.0
« Reply #3 on: April 30, 2016, 01:10:04 PM »
Thanks for the quick reply, Rdl.

I deleted all my backup servers, leaving only 1 server configured, and the speed limit worked properly when I set my max download speed as my real connection speed. Setting the limit to 50% actually downloaded at half of the max download speed I set.

Looks like the speed is being divided between all the levels, just like you said.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: Speed throttling not working correctly in v42.0
« Reply #4 on: July 29, 2016, 01:38:55 PM »
Partialy fixed now. Speed is divided by primary servers.

Partial cause it should be dynamic (take account of backups when they are working)