Author Topic: RSS problem  (Read 9144 times)

Offline franzdoe

  • Contributor
  • ***
  • Posts: 9
RSS problem
« on: November 14, 2008, 12:25:25 AM »
Hi,
I'm using 0.28.3 on WinXP, and i'm running into an issue:

RSS will not download files from feeds, mostly not even manually (Add to queue)

I'm getting the following messages in the log:
[14.11.2008 0:07:32] [NZB] D:\dir\xy.nzb imported - 0 files
(by filter or by add to queue)

But if i add them manually from the rss feed (by using the web browser by example) everything is ok, and file starts downloading.
Log: [14.11.2008 0:07:55] [NZB] D:\dir\xy.nzb imported - 29 files

I've checked the rss feed and the linked nzb, and everything is in order.
I've tried multiple RSS feeds (tvnzb and nzbsrus).

Thanks for your help.

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS problem
« Reply #1 on: November 14, 2008, 12:32:02 AM »
Maybe you missed this thread and others like it:

https://www.altbinz.net/forum/index.php?topic=2520.0

Edit: In short, database problem is intermittent, try tvbinz.net instead to confirm that it's 99.9% likely nothing to do with Alt.Binz.

NZBsRus is another issue - that feed requires authentication for direct download from RSS ... search the forum for instructions.
« Last Edit: November 14, 2008, 12:35:48 AM by Hecks »

Offline franzdoe

  • Contributor
  • ***
  • Posts: 9
Re: RSS problem
« Reply #2 on: November 14, 2008, 11:15:29 AM »
Hi,

I haven't missed the thread, I've read it and tested the TVnzb feed in the browser. Everything was ok with the feed.

...
But if i add them manually from the rss feed (by using the web browser by example) everything is ok, and file starts downloading.
...

I'm also aware of the auth required for nzbsrus, the link for the feed is copied directly from their pages, and works well in a browser (cleared cookies, so no chance of the feed pulling the auth from cookie)

This morning one out of five nzbs that the filter picked up imported correctlly from tvnzb.

TVbinz is working ok, for the moment.

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS problem
« Reply #3 on: November 14, 2008, 05:29:39 PM »
To repeat: the tvnzb.com problem has nothing to do with Alt.Binz.  The site serves the NZBs fine one minute, then it doesn't the next.  It's just coincidence that you happen to be using the browser when it does.  Maybe you haven't yet seen the times when all entries in the feed disappear, even with a browser?  The SABnzbd folks are also complaining about this.

Anyway, believe me or don't believe - but this isn't something that needs a bugfix here.  A new feature that could compensate for the site's crapness is another matter though ... like SABnzbd's retries, but better. ;)

NZBsRus I can't help you with, then.  Somebody else?  Tvbinz I guarantee works 100% of the time.

Edit: I've posted this request, which may or may not help:

https://www.altbinz.net/forum/index.php?topic=2542
« Last Edit: November 14, 2008, 05:55:29 PM by Hecks »

Offline franzdoe

  • Contributor
  • ***
  • Posts: 9
Re: RSS problem
« Reply #4 on: November 14, 2008, 07:16:41 PM »
Thanks for your help.

Hopefully the new features you suggested will help with this and other unreliable sites.  ;)

Offline Hitcher

  • Contributor
  • ***
  • Posts: 14
Re: RSS problem
« Reply #5 on: November 17, 2008, 10:42:54 AM »
All files I try to add manually from the TVnzb RSS feed get 0 files -

edited
« Last Edit: November 17, 2008, 11:23:36 PM by Hecks »

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS problem
« Reply #6 on: November 17, 2008, 11:25:02 PM »
Please read my message above.  To repeat for the final time: this has nothing to do with any version of Alt.Binz, but is a result of the intermittent service from tvnzb.com - working one minute, not working the next.


Offline Hitcher

  • Contributor
  • ***
  • Posts: 14
Re: RSS problem
« Reply #7 on: November 18, 2008, 12:48:34 AM »
But doesn't it seem strange that the minute I use 0.28.3 it doesn't work but as soon as I use 0.28.2 it does?

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS problem
« Reply #8 on: November 18, 2008, 01:51:26 AM »
Hmm, after some more investigating, there does seem to be another issue here now.  Download from tvnzb.com fails with NZBs over a certain size (works with smaller ones, and other sites)., and this isn't a problem in 0.25.0.

No idea why, sorry ...

Offline Jonathan

  • Contributor
  • ***
  • Posts: 5
Re: RSS problem
« Reply #9 on: November 23, 2008, 04:42:33 AM »
Thanks for clearing this up, I too was thinking that it was a bug.
« Last Edit: November 23, 2008, 05:55:38 AM by Hecks »

Offline Hecks

  • Global Moderator
  • *****
  • Posts: 2011
  • naughty cop
Re: RSS problem
« Reply #10 on: November 30, 2008, 01:21:54 PM »
This could be the source of the problem:

"Compressed downloading not sending corrent content length?"
http://www.tvnzb.com/forum/viewtopic.php?t=51969

Offline Hoox

  • Contributor
  • ***
  • Posts: 3
Re: RSS problem
« Reply #11 on: December 12, 2008, 02:38:45 PM »
Any news on the progress on fixing this RSS bug?

Offline Ashe

  • Contributor
  • ***
  • Posts: 16
Re: RSS problem
« Reply #12 on: December 15, 2008, 09:57:17 PM »
I combine multiple RSS feeds together, and with 0.28.2 one of the sites doesn't work, with 0.28.3, it's the other site that doesn't work.

In the meantime, until it's fixed, I've installed the Webcleaner proxy onto my computer and route Alt.Binz HTTP through that as it sorts the problem.

Offline Rdl

  • Administrator
  • *****
  • Posts: 3506
Re: RSS problem
« Reply #13 on: January 20, 2009, 09:51:41 PM »
Fixed.
Same thing done for nzbs.org
« Last Edit: January 20, 2009, 11:20:25 PM by Rdl »